AI Zone Admin Forum Add your forum

NEWS: survey on 3000 US and UK consumers shows it is time for chatbot integration in customer service!read more..

Make a bot ignore files outside RAWDATA?

Hi guys!
Ive been having fun going through the massive lists of :topics and :concepts that come with CS and working out how it all comes together. I do occasionally get errors when i write my own into a bots file (They already exist or seem to clash with another), so what I would like to do though is start completely from scratch so as to better learn the basics.

Is there a simple way to have a bot draw its data from its own RAWDATA files only?

Thanks in advance grin


  [ # 1 ]

Since this post I’ve tried a few things to get around the build errors. Some concepts/topics pull errors, some don’t and I’m unsure why. Im thinking I may have missed a point or two in the manual about topics and concepts?

Erasing WORLDDATA and ONTOLOGY works. Erasing the ONTOLOGY/ENGLISH/ works.
Putting ~bob_whateverthetopicis works. But I’m trying to understand the cause of these errors, not get around them.

Today I did a fresh install of CS. I created my own concept file to match some files with topics inside written simply like below. I did colour, animals, dance, flow_art and ocean. Yesterday ~animals and ~dance pulled “concept already defined” errors, yet today they hold to the keywords I set in bob_concepts. ~ocean still pulls the build error “concept already defined”.

If I rename to colour also pulls the same error. So why would some concepts and topics pull the error and not others, when they are all in the ontology/concept file?

topic: ~animals keep []

u: (~animals) ^keep() ^repeat() Topic animals!

All the files I created are in RAWDATA/bob


  [ # 2 ]

Should anyone else new to CS come along this with a similar confusion:

A concept and a topic can share a name. An error stating one is already defined means exactly that. In my example above, ~animals was already defined in TOPIC/BUILD0/keywords0.txt

Took me awhile to find it. Although, the file only gave me this problem sometimes. I hope this helps someone in the future wink


  login or register to react