AI Zone Admin Forum Add your forum

NEWS: survey on 3000 US and UK consumers shows it is time for chatbot integration in customer service!read more..

New to Chatscript, installing on a Mac—have a question

Hi All,
I am new to ChatScript. I installed CS 7.11 on my MacbookPro (OS 10.12) and it seems to load using ./MacChatScript local, except once I get to where the HARRY prompt should be, I just get a plain prompt “>”—and if I say “hello” I get nothing.
I followed the instructions available here:


  [ # 1 ]

Did you build the user you created, or HARRY?

type the following four commands:

:build 0
:build harry

Did you try the binary in BINARIES/MacChatScript?

What is the output of the binary when it starts up?

For more advanced and detailed instructions try checking out the new mac instructions at:

It sounds however like your problem is that the bot isn’t compiled or something like that.



  [ # 2 ]

Hi Todd,
Thanks so much for your speedy reply.
Yes, I was in BINARIES and I used ./MacChatScript local at the command line.
I typed :who and it tells me I am talking with harry—then the others seem normal, then :who tells me I’m talking with harry again. But still the prompt is “>” only and no response to my “hello”.
Yes, it does sound like the bot isn’t compiled.
I did originally successfully compile using 7.01, about a week ago, but there was a bug that I corresponded with Bruce about and decided to use an earlier or later version to see if that worked. I got the same problem (no “harry” at the prompt, no responses) with both 6.9 and 7.01.
I looked at the Mac instructions—I am using the outdated BINARIES method. Not much to it, but I don’t know why it doesn’t compile. Any help you have would be useful. Thanks so much!


  [ # 3 ]

what directory are you running in?

It should be ‘BINARIES/MacChatScript local’ if you are running it in the correct directory, i.e. the root of the chatscript folder.


  [ # 4 ]

Yes, running in BINARIES.


  [ # 5 ]

I would try deleting the entire chatscript directory and starting fresh.  Don’t follow the instructions for creating a new bot or anything, just start with the default chatscript download.  Go to the top level folder _not_ BINARIES and execute

BINARIES/MacChatScript local 

as described in the mac manual I sent you link to before. 

Then the four commands I mentioned before when you get the prompt.  Post the output of that activity here. That will rule out chatscript as the problem.


  [ # 6 ]

Okay, actually, I got a whole new download and tried it and it worked…so we’re set. Thank you for your time! A huge help!


  login or register to react